WordPress最新安全漏洞2021年3月

作者 : 玄天 本文共1516个字,预计阅读时间需要4分钟 发布时间: 2021-03-18
研究人员已经披露了多个WordPress插件中的漏洞,如果成功利用这些漏洞,则攻击者可以在某些情况下运行任意代码并接管网站。
这些缺陷已在Elementor一个用于超过500万个网站的网站构建器插件)和WP Super Cache(用于服务WordPress网站的缓存页面的工具)中发现。
Elementoc插件安装量为500万
WP Super Cache安装量为200万

Elementoc插件xss漏洞

据发现在Elementor中存在安全漏洞的Wordfence称,该错误与一组存储的跨站点脚本(XSS)漏洞(CVSS评分:6.4)有关,该漏洞是在将恶意脚本直接注入易受攻击的Web应用程序时发生的。
在这种情况下,由于在服务器端缺乏对HTML标记的验证,不良行为者可以利用这些问题,通过精心设计的请求将可执行JavaScript添加到帖子或页面中。
Wordfence在一份技术文章中说: “由于贡献者创建的帖子通常在发布之前由编辑或管理员进行审核,因此添加到其中一个帖子中的任何JavaScript都将在审阅者的浏览器中执行。” Wordfence在技​​术文章中说道。“如果管理员审阅了包含恶意JavaScript的帖子,则可以使用其具有高级别特权的经过身份验证的会话来创建新的恶意管理员,或为网站添加后门。对该漏洞的攻击可能导致网站被接管。”
发现多个HTML元素(如标题,列,手风琴,图标框和图像框)容易受到所存储的XSS攻击,从而使任何用户都可以访问Elementor编辑器并添加可执行的JavaScript。
鉴于这些缺陷利用了以下事实:可以利用模板中输入的动态数据来包含旨在发动XSS攻击的恶意脚本,因此可以通过验证输入并转义输出数据来阻止此类行为,以便HTML标记作为输入变得无害。
漏洞详情
说明: 受影响的多个身份验证的存储跨站点脚本(XSS)插件: Elementor 插件插件: elementor 受影响的版本: <3.1.2 CVE ID:待处理的 CVSS得分: 6.4中等 CVSS得分:CVSS:3.1 / AV:N / AC:L / PR:L / UI:N / S:C / C:L / I:L / A:N 完整版本: 3.1.4
时间线
20212月23日– Wordfence威胁情报向高级用户发布了防火墙规则,并向Elementor安全联系人提供了全面的披露。 20212月24日– Elementor承认此披露,并开始进行修复。 20213月2日–版本3.1.2中提供了一个初始补丁。 20213月8日–在版本3.1.4中进行了其他修复。 20213月25日-防火墙规则对免费用户可用。
在2月23日进行负责任的披露之后,Elementor通过强化“允许在编辑器中执行更好的安全策略的选项”,修复了3月8日发布的3.1.4版本中的问题。
注意事项
我们发现的漏洞存在于Elementor的免费版本中,需要安装该免费版才能使Elementor Pro正常运行。也就是说,如果您已安装Elementor Pro,则仍应确保使基础Elementor安装保持最新。
WP Super Cache远程代码执行漏洞(RCE)
另外,在WP Super Cache中发现了一个经过身份验证的远程代码执行(RCE)漏洞,该漏洞可能允许攻击者上传和执行恶意代码,以期获得对该站点的控制权。据报道,该插件已在超过200万个WordPress网站上使用。
WP Super Cache背后的开发人员Automattic表示,它解决了1.7.2版中的“设置页面中经过身份验证的RCE”。
强烈建议插件的用户更新到最新版本,以减轻与漏洞相关的风险。
受影响的版本详情
WP Super Cache<= 1.7.1 披露日期: 2021-03-16

版权声明

【部分资源需要解压密码 如需密码加入QQ群:565551344或者点击此处在线获取解压密码
本站所发布的一切源码、模板、应用等文章仅限用于学习和研究目的;不得将上述内容用于商业或者非法用途,否则,一切后果请用户自负。本站信息来自网络,版权争议与本站无关。您必须在下载后的24个小时之内,从您的电脑中彻底删除上述内容。如果您喜欢该程序,请支持正版,购买注册,得到更好的正版服务。如有侵权请邮件与我们联系处理。

极客猫 » WordPress最新安全漏洞2021年3月